Outage for connection with CVR

Incident Report for Meo

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 17:28 CEST

Investigating

Our connection with the CVR database is having an outage and we are investigating and fixing the issue.
Posted Jul 09, 2026 - 12:57 CEST
This incident affected: Third-Party Providers (CVR).